大华官方的解决方法:打开IE浏览器,点击帮助查看版本

现在的安防视频监控系统一般都内置WEB服务,一些关键参数可以通过浏览器进行修改和调整。在实际项目调试过程中,我们会发现由于现场电脑原因,遇到很多浏览器版本错误导致的兼容性故障:页面显示不正确,部分功能无法使用。即使已经安装了插件,还是反复提示安装插件,页面无法正常。

如果客户端电脑的IE版本太高点击事件兼容性写法,与现有设备的插件版本不兼容,调试时紧急使用以下方法,简单快捷。

打开 Internet Explorer 并单击帮助以查看版本。

输入设备IP地址,直接使用IE打开设备网页点击事件兼容性写法,使用F12快捷键或点击菜单→工具→F12开发者工具打开开发者工具,切换到设备兼容的IE版本(如V< @9.0),则网页将恢复正常使用。

厂家的解决方案稍微复杂一些,设置可能无法正常工作。

1、大华官方解决方案:

第 1 步:打开 Internet Explorer – 工具

第 2 步:选择 Internet 选项 – 安全 – 自定义级别

第 3 步:“初始化并编写未标记为安全的 ActiveX 控件”和“下载未签名的 ActiveX 控件”均已启用

第四步:工具——兼容性视图设置——“在兼容性视图中显示所有网站”打勾

第五步:在网页上重新登录设备。如果提示加载控件,点击“请点击此处下载插件”或在弹出的对话框中运行该控件,点击允许。

海康官方的做法类似,具体方法如图

图片[1]-大华官方的解决方法:打开IE浏览器,点击帮助查看版本-老王博客

单击工具 – 兼容性视图设置

兼容性设置

添加兼容站点

单击工具 – Internet 选项

互联网设置

在安全选项中配置受信任站点

添加受信任的站点

设置完成后重启浏览器,访问设备,提示安装插件时确认安装,然后按F5键刷新浏览器即可正常访问。

海康威视目前使用 NPAPI 插件在网络浏览器中显示视频,Google Chrome v45(自 2015 年 9 月起)和 Firefox v52.0(2017 年 3 月 7 日发布)NPAPI 插件不再支持该插件。可以通过在 Chrome 中安装 IEtab 扩展来模拟 IE,它会正常显示视频。

其他浏览器支持的功能

建议使用 32 位 IE 浏览器。海康威视的 WebComponents 插件不支持 64 位系统。其他 Chrome、Firefox、Safari 功能不全。

© 版权声明
THE END
喜欢就支持一下吧
点赞0
分享
评论 抢沙发

请登录后发表评论